
 

 
 

Toolbox for HMI 
projects 

 
SIMATIC WinCC Professional V15.1 
SIMATIC STEP 7 Professional V15.1 
 

https://support.industry.siemens.com/cs/ww/en/view/106226404 

 
 

Siemens 
Industry 
Online 
Support 

https://support.industry.siemens.com/cs/ww/de/view/106226404


Legal information 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  2 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

Legal information 
Use of application examples 

Application examples illustrate the solution of automation tasks through an interaction of several 
components in the form of text, graphics and/or software modules. The application examples are 
a free service by Siemens AG and/or a subsidiary of Siemens AG (“Siemens”). They are non-
binding and make no claim to completeness or functionality regarding configuration and 
equipment. The application examples merely offer help with typical tasks; they do not constitute 
customer-specific solutions. You yourself are responsible for the proper and safe operation of the 
products in accordance with applicable regulations and must also check the function of the 
respective application example and customize it for your system. 
Siemens grants you the non-exclusive, non-sublicensable and non-transferable right to have the 
application examples used by technically trained personnel. Any change to the application 
examples is your responsibility. Sharing the application examples with third parties or copying the 
application examples or excerpts thereof is permitted only in combination with your own products. 
The application examples are not required to undergo the customary tests and quality inspections 
of a chargeable product; they may have functional and performance defects as well as errors. It is 
your responsibility to use them in such a manner that any malfunctions that may occur do not 
result in property damage or injury to persons. 
 

Disclaimer of liability 
Siemens shall not assume any liability, for any legal reason whatsoever, including, without 
limitation, liability for the usability, availability, completeness and freedom from defects of the 
application examples as well as for related information, configuration and performance data and 
any damage caused thereby. This shall not apply in cases of mandatory liability, for example 
under the German Product Liability Act, or in cases of intent, gross negligence, or culpable loss of 
life, bodily injury or damage to health, non-compliance with a guarantee, fraudulent 
non-disclosure of a defect, or culpable breach of material contractual obligations. Claims for 
damages arising from a breach of material contractual obligations shall however be limited to the 
foreseeable damage typical of the type of agreement, unless liability arises from intent or gross 
negligence or is based on loss of life, bodily injury or damage to health. The foregoing provisions 
do not imply any change in the burden of proof to your detriment. You shall indemnify Siemens 
against existing or future claims of third parties in this connection except where Siemens is 
mandatorily liable. 
By using the application examples you acknowledge that Siemens cannot be held liable for any 
damage beyond the liability provisions described. 
 

Other information 
Siemens reserves the right to make changes to the application examples at any time without 
notice. In case of discrepancies between the suggestions in the application examples and other 
Siemens publications such as catalogs, the content of the other documentation shall have 
precedence.  
The Siemens terms of use (https://support.industry.siemens.com) shall also apply.  
 

Security information 
Siemens provides products and solutions with industrial security functions that support the secure 
operation of plants, systems, machines and networks. 
In order to protect plants, systems, machines and networks against cyber threats, it is necessary 
to implement – and continuously maintain – a holistic, state-of-the-art industrial security concept. 
Siemens’ products and solutions constitute one element of such a concept. 
Customers are responsible for preventing unauthorized access to their plants, systems, machines 
and networks. Such systems, machines and components should only be connected to an 
enterprise network or the Internet if and to the extent such a connection is necessary and only 
when appropriate security measures (e.g. firewalls and/or network segmentation) are in place.  
For additional information on industrial security measures that may be implemented, please visit 
https://www.siemens.com/industrialsecurity. 
Siemens’ products and solutions undergo continuous development to make them more secure. 
Siemens strongly recommends that product updates are applied as soon as they are available 
and that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customer’s exposure to cyber 
threats. 
To stay informed about product updates, subscribe to the Siemens Industrial Security RSS Feed 
at: https://www.siemens.com/industrialsecurity. 
 

https://support.industry.siemens.com/
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1 Introduction 
The HMI toolbox of Siemens Industry Online Support provides many useful tools 
that can clearly make every day work easier.   

The different tools are available in global libraries and can thus be easily integrated 
in your visualization. This saves you valuable development time that you would 
have to invest in the development of your own tools. 

 

The HMI toolbox comprises tools for six different subject areas. 

• "Time functions" 

• "Transfer data" 

• "Mathematical functions" 

• "Simplified operation" 

• "Increase clarity" 

• "Simplified engineering" 

 

A separate section is available in this document for each subject area. A library 
with all tools and an example project that shows the application of the tools is 
available. 

Application example  
"Example project for WinCC Runtime Professional V15.1": 

• Engineering: STEP 7 Professional / WinCC Professional V15.1  

• HMI operator panel: PC station with WinCC RT Professional 

• Controller: SIMATIC CPU S7-1516F-3 PN/DP. 

 

Note For some tools a PLC is required in combination. 

You should therefore note the hardware and software requirements at the 
beginning of each section. 

Depending on the size of the HMI operator panel, it may be necessary to adapt 
the screens. 

 

https://support.industry.siemens.com/cs/attachments/106226404/106226404_ExampleProject.zip
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2 Time functions 

2.1 Time-of-day alarm / Alarm 

2.1.1 Solution 

Description 

You can use the time-of-day alarm / alarm to be reminded of a specific event in 
Runtime at a specific time (time-of-day) via a screen. 

The time must be set in the format (hh:mm:ss) by means of three I/O fields directly 
in the screen. Use the switch to activate the time-of-day alarm / alarm. 

The PLC compares the current time with the time of the time-of-day alarm / alarm 
and triggers an alarm when the set time has been reached. 

In the status bar you can see when the alarm has expired. Press the status bar to 
acknowledge the alarm.  

If you trigger a screen change before the alarm is triggered, the alarm is still 
maintained.  

 

Figure 2-1 

 

 

2.1.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional and STEP 7 Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

• SIMATIC S7-1200/S7-1500 

 

2.1.3 Data types and function blocks used 

FC "LGF_DTLtoString"  

The function block "LGF_DTLtoString" has been applied from the "Library with 
general functions (LGF) for STEP 7 (TIA Portal) and S7-1200 / S7-1500" library. 
This block converts date components of the data type DTL to a character string of 
the String format. 

More information on this function block is available under the associated entry  
ID 109479728. 

 

FB "LProfToolbox_Alarm" 

The function block "LProfToolbox_Alarm" compares the entered alarm time with 
the system time. If both match, the function block sets an "elapsed" alarm status 
and returns the current system time "elapsedTime". 

https://support.industry.siemens.com/cs/ww/en/view/109479728
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2.1.4 Project Planning 

Table 2-1 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. To do this, open the "Global libraries" pane in the 
"Libraries" task card. 

 

3. Click on the second icon from the left to open a "Global Library". 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

5. Open the folder "Master copies > HMI > Tools > 01_Time functions > Alarm" of the 
library. 

Drag the elements to the corresponding folder of the HMI operator panel. 

 
 

Note 
Depending on the size of the HMI operator panel, it may be necessary to adapt the 
screens. 

If your HMI connection to the PLC is not called "HMI_Connection_1", update your 
HMI connection in the tag table. 

You must also synchronize the HMI tags again with the PLC tags. 
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No. Action 

6. Drag the data block "LProfToolbox_CommDB" to the "Program blocks" folder of 
your PLC. 

 

 
 

All tags that are required for the time-of-day alarm have the prefix "alarm". Delete all 
other tags from the data block "LProfToolbox_CommDB". 

7. Open the "Types" folder of the library and drag the function block 
"LProfToolbox_Alarm" to the program blocks folder of your PLC.  

 

 
 

Note 
The block "LGF_DTLtoString" is created automatically in the project. 

You only need the function block "LGF_DTLtoString" if it has not been integrated 
into your project yet. 

8. Call the function block "LProfToolbox_Alarm" in your user program and interconnect 
the inputs and outputs with the respective tags of the communication DB. 

 

Block from library  
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No. Action 

9. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Time_Screenwindow 

- Configuration "LProfToolbox_Time_Configuration"  

- Tag "LProfToolbox_Time_Tag".  

 

Alternatively, configure your own screen window by calling the screen window 
"Alarm". Note that additional steps (e.g. adapting the screen window name in 
scripts) may be necessary in this case. 

 

 
 

Note: 

The toolbar "LProfToolbox_Time_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

10 Deselect the default configuration under "Menus & toolbar →Configurations". 
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2.1.5 Operation 

Table 2-2 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click on the "Time functions" button in the navigation bar at the bottom.  

 

 
 

Open the pop-up screen with the "Alarm" button. 

 
 

5. Enter the time when the alarm is to appear. Enable the alarm with the "On" switch. 

 

6. Click the "Alarm expired at" button to acknowledge the alarm. 
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2.2 Calendar 

2.2.1 Solution 

Description 

The calendar provides an overview of individual days of the current and the next 
month. The current day is highlighted in red.  

You can enter up to 30 appointments in the calendar with the "Events" button. The 
calendar will remind you of any pending events that are scheduled. 

The events are saved in the file system of the operator panel for this purpose. 

This tool does not depend on a PLC. The calculations are performed by the HMI 
operator panel. 

 

Figure 2-2 

 

 

2.2.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 
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2.2.3 VBS scripts used 

The individual functions of the calendar are solved with the help of multiple scripts. 
You may be able to use these scripts for other areas of application. 

LProfToolbox_CalendarEvent 

The "LProfToolbox_CalenderEvent" script is used for event management. The 
events are stored in the "events.txt" file with the associated time stamp and 
reminder text. The script handles the following tasks: 

• Initialize the event entries 

• Create and save a new event 

• Delete an existing event 

• Transfer the parameters to the associated HMI tags. 

LProfToolbox_GenerateCalendar 

The "LProfToolbox_GenerateCalendar" script generates the calendar overview 
with the current month and next month based on the current date. 

LProfToolbox_TransferSenderDate 

The "LProfToolbox_TransferSenderDate" script reads the date of the selected day 
in the calendar and transfers the date to the input screen for a new event. 

 

 

2.2.4 Project Planning 

Table 2-3 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

Open the "Global libraries" pane in the "Libraries" task card. 

 

3. Click on the second icon from the left to open a "Global Library". 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 
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No. Action 

5. Open the folder "Master copies > HMI > Tools > 01_Time functions > Calendar" of 
the library. 

Drag the elements to the corresponding folders of the operator panel. 

 
 

Note 

Depending on the size of the HMI operator panel, it may be necessary to adapt the 
screens. 
If your HMI connection to the PLC is not called "HMI_Connection_1", update your 
HMI connection in the tag table. 

You must also synchronize the HMI tags again with the PLC tags. 

6. Call the scripts "LProfToolbox_GenerateCalender" and "LProfToolbox_Calendar 
Event" at the "Loaded" event of your start screen so that the events are loaded. 

7. Optional:  
When you adapt the size of the calendar, enter the changed height or width of a 
calendar day I/O field as start value for the tags "calendarFieldHeight" and 
"calendarFieldWidth" in the "LProfToolbox_Tags_Calendar" tag table. The position of 
the selection frame is calculated based on these tags. 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Time_ScreenWindow" 

- Configuration "LProfToolbox_Time_Configuration"  

- Tag "LProfToolbar_Time_Tag". 

 

Alternatively, configure your own screen window by calling the screen 
"LProfToolbox_Calendar". Note that additional steps (e.g. adapting the screen 
window name in scripts) may be necessary in this case. 
 

Note: 

The toolbar "LProfToolbox_Time_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 
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No. Action 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

 

2.2.5 Operation 

Table 2-4 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click on the "Time functions" button. 

 
Click on the "Calendar" button. 

 

 
 

5. To add an event, click on a day. The "Add reminder" dialog opens with the selected 
date. 
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No. Action 

6. Adjust the time and the text and save the event entry with the "Apply" button.

 
Note 

Confirm the entry with "Enter" in the I/O field. 
Note that you can only enter events in the future. 

7. Click on the "Events" button in the "Calendar" screen.  

 

You will see an overview of upcoming events. These are automatically sorted in 
ascending order. 

 

Note 

Use the buttons on the right to delete an event. 

To change an event, click in the corresponding I/O field and enter the changed time 
or text. 
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2.3 Stopwatch 

2.3.1 Solution 

Description 

You can monitor and record the duration of production steps in your plant with the 
stopwatch. 

The stopwatch is started with the "START" button and stopped with the "STOP" 
button. The PLC calculates the lap time. 

The stopwatch can save up to 5 lap times and display them on your HMI operator 
panel. The lap time is recorded with the "Lap" button. The stopwatch stops once 
the five lap times have been recorded. You can reset the stop and lap times with 
the "RESET" button. 

 

Figure 2-3 

 

 

2.3.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional and STEP 7 Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

• SIMATIC S7-1500 
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2.3.3 Data types and function blocks used 

Data type "LProfToolbox_Time_typeRoundStopwatch" 

The data type "LProfToolbox_Time_typeRoundStopwatch" defines the stop / lap 
times as data format "Time" as well as the associated number of minutes and 
seconds. 

 

Table 2-5: Parameters of typeRound 

Name Data type Comment 

time Time Total time 

min Int Number of minutes 

sec Int Number of seconds 

FB "LProfToolbox_Stopwatch" 

The function block "LProfToolbox_Stopwatch" starts an internal timer that 
calculates the stop time "total" as well as the individual lap times ("round1" – 
"round5").  
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2.3.4 Project Planning 

Table 2-6 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

Open the "Global libraries" pane in the  
"Libraries" task card. 

 

3. Click on the second icon from the left to open a "Global Library". 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

5. Open the folder "Master copies > HMI > Tools > 01_Time functions > Stopwatch" of 
the library. 

Drag the elements to the corresponding folder of the HMI operator panel. 

 
Note 

If your HMI connection to the PLC is not called "HMI_Connection_1", update your 
HMI connection in the tag table. 

Depending on the size of the HMI operator panel, it may be necessary to adapt the 
screens. 

You must also synchronize the HMI tags again with the PLC tags. 
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No. Action 

6. Drag the data block "LProfToolbox_CommDB" to the "Program blocks" folder of your 
PLC. 

  
Delete all other tags you do not need from the data block. 

7. Open the folder "Types > 03_Tools > 01_Blocks > TimeFunctions > Stopwatch" of the 
library.  

Drag the function block "LProfToolbox_Stopwatch" to the "Program blocks" folder of 
your PLC. 

 

8. Call the function block "LProfToolbox_Stopwatch" in your user program and 
interconnect the inputs and outputs with the respective tags of the communication 
DB. 
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No. Action 

9. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Time_Screenwindow" 

- Configuration "LProfToolbox_Time_Configuration"  

- Tag "LProfToolbox_Time_Tag". 

 

Alternatively, configure your own screen window by calling the screen window 
"Stopwatch". Note that additional steps (e.g. adapting the screen window name in 
scripts) may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Time_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

10. Deselect the default configuration under "Menus & toolbar →Configurations". 
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2.3.5 Operation 

Table 2-7 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click on the "Time functions" button. 

 
Open the stopwatch with the "Stopwatch" button. 

 

5. Start the stopwatch with the "Start" button.  

 

6. Use the "Round" button to take a current lap time and start a new lap. 
Use the "Stop" button to pause/cancel the stopwatch. 

 
 

Note 

When all lap times are full and you start the stopwatch again, the lap time of lap 5 is 
overwritten the next time you click on the "Round" button. 
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No. Action 

7. Use the "Reset" button to reset the values of the stop and lap times. 
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2.4 Timer 

2.4.1 Solution 

Description 

You use the timer to have the system remind you of an event after a defined 
runtime has elapsed.  

By default, the timer offers five runtimes (1 min, 2 min, 5 min, 10 min, 15 min). You 
set the runtime by pressing the associated button. 

The PLC starts a timer with the specified runtime and triggers an alarm when this 
time has expired.  

In the status bar you can see when the timer has expired. Press the status bar to 
reset the timer.  

When you trigger a screen change before the timer is triggered, the timer still 
remains active. 

 

Figure 2-4 

 

 

2.4.2 Hardware and software components 

The application example is valid for: 

• STEP 7 Professional V15.1 

• SIMATIC WinCC Professional and STEP 7 Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

• SIMATIC S7-1500 
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2.4.3 Function blocks used 

FC "LGF_DTLtoString"  

The function block "LGF_DTLtoString" has been applied from the "Library with 
general functions (LGF) for STEP 7 (TIA Portal) and S7-1200 / S7-1500" library. 
This block converts a character string of the format "String" with date components 
into the data type DTL. 

More information on this function block is available at the following link: 
https://support.industry.siemens.com/cs/ww/en/view/109479728. 

FB "LProfToolbox_Timer" 

The function block "LProfToolbox_Timer" starts a timer with the runtime "duration". 
When this runtime has expired, the function block sets an alarm status "elapsed" 
and returns the current system time "elapsedTime". 

 

2.4.4 Project Planning 

Table 2-8 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

To do this, open the "Global libraries" pane in the "Libraries" task card. 

 

3. Click on the second icon from the left to open a "Global Library". 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

https://support.industry.siemens.com/cs/ww/en/view/109479728
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No. Action 

5. Open the folder "Master copies > HMI > Tools > 01_Time functions > Timer" of the 
library. 

Drag the elements to the corresponding folder of the HMI operator panel. 

 

 
 

Note 

If your HMI connection to the PLC is not called "HMI_Connection_1", update your 
HMI connection in the tag table. 

Depending on the size of the HMI operator panel, it may be necessary to adapt the 
screens. 

You must also synchronize the HMI tags again with the PLC tags. 

6. Drag the data block "LProfToolbox_CommDB" to the "Program blocks" folder of 
your PLC. 

 
 

Delete the tags that are not needed for the timer from the data block 
"LProfToolbox_CommDB". 

7. Open the "Types" folder of the library and drag the function block 
"LProfToolbox_Timer" to the program blocks folder of your PLC.  

 

               
 

Note 

You only need the function block "LGF_DTLtoString" if it has not been integrated 
into your project yet. 
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No. Action 

8. Call the function block "LProfToolbox_Timer" in your user program and interconnect 
the inputs and outputs with the respective tags of the communication DB. 

 

 
 

9. Drag the following objects from the library to your project:  

- Screen window "LProfToolbox_Time_ScreenWindow" 

- Configuration "LProfToolbox_Time_Configuration"  

- Tag "LProfToolbox_Time_Tag". 

 
Alternatively, configure your own screen window by calling the screen window 
"Timer". Note that additional steps (e.g. adapting the screen window name in 
scripts) may be necessary in this case. 

 

 
 

Note: 

The toolbar "LProfToolbox_Time_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

10. Deselect the default configuration under "Menus & toolbar →Configurations". 
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2.4.5 Operation 

Table 2-9 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click on the "Time functions" button.  

 
Open the timer with the "Timer" button. 

 

5. Select a runtime for the timer and start the timer using the "Start" button.  

 

Use the "Stop" button to pause the timer during runtime. 

6. Click on the "Timer expired at: …" button to acknowledge the timer. 

 



3 Data transfer 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  29 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

3 Data transfer 

3.1 Barcode 

3.1.1 Solution 

Description 

To show a barcode in Professional, you must install a corresponding font.  

You can find numerous providers of these fonts on the Internet. The "Code-39-
Logitogo Version V1.0 (with width check)" font was used for the application 
example. You can find additional information on this in the document list under /5/. 

A screen with multiple text boxes is used to enter data for a delivery note. For 
illustration purposes, the barcodes of the previously entered texts are displayed.  

 

Figure 3-1 

 

 

The barcode is created by direct input using a "TrueType font". Depending on the 
respective barcode type, a start and stop character is expected, for example, "*" for 
the Code39 used in the example.  

For detailed information on the design of the different barcode fonts, please refer to 
the appropriate font documentation.  

Note The application example was tested with the font "Code 39" from Logitogo in 
version 1.00. The functionality cannot be guaranteed for other font versions. 
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3.1.2 Hardware and software components 

The application example is valid for 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

 

3.1.3 VBS scripts used 

The script "AddStartStopSign" adds a "*" as start and stop character to the entered 
string tags and saves this string in the HMI tag for the barcode. 

 

3.1.4 Installing the barcode font under Windows 10 

There are three options to install the font under Windows 7 .  

Note Close all instances of the TIA Portal prior to the installation.  

If an instance of the TIA Portal was open during the installation of the font, close 
the TIA Portal and then restart it. 

Option 1 

 

Table 3-1 

No. Action 

1. Open the file with the barcode font by double clicking it. The font preview 
opens. 

2. Click "Install". 

 
Note 
You need to have the required administrator rights to do this. 

3. Complete the installation. 
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Option 2 

Table 3-2 

No
. 

Action 

1. Right-click the barcode font file. The shortcut menu opens. 

 

2. Click "Install". 

 
Note 
You need to have the required administrator rights to do this. 

3. Complete the installation. 

 

Option 3 

Table 3-3 

No. Action 

1. Select the file for the barcode font and copy the file using the key combination <Ctrl> 
+ <C>. 

2. Open the "Fonts" folder in the Control Panel. 

3. Add the "SiemensTIAPortalIcons.ttf" file with the key combination <Ctrl> + <V>. 
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3.1.5 Integrating a font into your project 

When you configure a PC station with SIMATIC WinCC Professional, you do not 
have to integrate the font. You only have to install the font on the operating system. 
All installed fonts of the Windows operating system are available for the 
configuration. 

 

 

3.1.6 Using a font 

Setting the font, font style and font size 

You have to manually customize the font, as well as associated font style and font 
size for basic objects and elements. 

 

Table 3-4 

No. Action 

1. Select a basic object. 

2. Click on "Properties > Text format". 

3. In "Format > Font", click the "…" button. 

4. Select the barcode font and set "Font style" and "Size" as desired. 

5. Click on "OK". 
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3.1.7 Project Planning 

Note The correct installation of the barcode font on your panel/your PC station, as well 
as the integration into your WinCC project is a prerequisite for the configuration. 

 

Table 3-5 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 02_Transferring Data > Barcode" 
of the library. 

Drag the elements to the corresponding folders of the operator panel. 

 

7. Open the "LProfToolbox_Barcode" screen. 
Check whether the installed barcode font is set for the two code output fields under 
"Properties > Text format". 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_TransferData_ScreenWindow" 

- Configuration "LProfToolbar_TransferData_Configuration"  

- Tag "LProfToolbar_TransferData_Tag". 
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No. Action 

 

Alternatively, configure your own screen window by calling the "Barcode" screen. 
Note that additional steps (e.g. adapting the screen window name in scripts) may be 
necessary in this case. 

 

 
 

Note: 

The toolbar "LProfToolbar_TransferData_Toolbar" is automatically transferred with 
the configuration. Check the toolbar and delete the tools that you are not using from 
the toolbar. 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

 

Note Add the event "SetTag" at the "Value change" event of the tag to be encoded. 
Under "Tag" select the tag through which the barcode is to be displayed, and 
under "Value" set the tag to be encoded. 
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3.1.8 Operation 

Table 3-6 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

Note: 

A barcode font must be installed for operation of the example project. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Data transfer" button. 

 
Open the File Explorer with the "Barcode" button. 

 

5. Enter the delivery note number, the article name and the article number using the 
input fields. The delivery note number and the article number are automatically 
displayed as barcode. 
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3.2 QR Codes 

3.2.1 Solution 

Description 

It is often useful to transfer information from operator panels or controllers to a cell 
phone or tablet PC. 

An option should be used without having to integrate the cell phone or tablet PC 
into the automation network. 

The PC station generates a QR code from the information to be transferred. The 
QR code can be read and interpreted by the cell phone or tablet PC. 

Figure 3-2 

 

 

3.2.2 Hardware and software components 

The application example is valid for: 

• SIMATIC WinCC RT Professional V15.1 
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3.2.3 Basics 

Structure of the QR code used 

Table 3-7 

QR code (marked with color) Meaning 

 

 Encoding type 

This QR code uses eight bit per character. 
This makes it possible to represent most 
ASCII characters. The encoding type is 
"0100" in binary format.  The property 
cannot be changed. 

 Length 

Specifies the number of characters used in 
the QR code. This code always contains 17 
characters. (If fewer characters are used, 
the script will add the missing characters.) 

 Data blocks 

The data blocks contain the encoded 
information. Based on the ASCII table, each 
character is converted into a byte and 
encoded in these blocks. 

 Error blocks 

The error blocks contain the error number 
of the "Reed-Solomon" algorithm \4\. 

 Formatting 

The formatting blocks contain information 
on the QR code structure. This application 
uses a simple structure. 

(Error level: L 
Mask pattern: i%2 = 0 
Meaning: The black blocks change the 
value depending whether the number is 
even or odd.) 

Basic functionality of the script 

The script calculates the binary code of the tags to be displayed using the default 
settings or the settings you have made.  
In addition, other information (information on error correction) is converted 
according to the "Reed-Solomon" algorithm. The result of the script is displayed 
using the "visibility" property of the individual elements (squares) of the QR code. 
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3.2.4 Project Planning 

Table 3-8 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. To do this, open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a global library. 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 02_Transferring Data > QRCode" of 
the library. Drag the elements to the operator panel. 

   

7. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

8. Open the VBS script "LProfToolbox_GenerateQRCode". 
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No. Action 

9. In line 36 of the script, check the name of the screen on which you have used the QR 
code and adapt it, if necessary.  

 

 

In line 56 of the script, check the name of the tag that you want to convert into the 
QR code and adapt it, if necessary.

 

 

3.2.5 Operation 

Table 3-9 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal.  

3. Download the configuration to your PC station or start the simulation.  

4. Click the "Data transfer" button. 

 

5. Open the QR code screen with the "QR Code" button. 

 

6. Enter a random text into the I/O field. 

The text is limited to 17 characters. 

 
Click "Generate" to convert the text  
into a QR code. 

 

  



3 Data transfer 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  40 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

3.3 Emails  

3.3.1 Solution 

Description 

As not all machines of a plant are permanently monitored by staff, it is often not 
possible to promptly react to pending alarms on the operator panel. 

An email notification is to offer help here. 

Using the application example, you can send emails automatically when specific 
alarms occur as well as manually from the IPC. 

Figure 3-3 

 

A three-shift system is also available for automatic sending of emails so that the 
employee in charge is automatically notified. 

Figure 3-4 

 

 

Known email addresses are backed up by a text file in the file system of the 
operator panel so that they are sill available after a restart. 
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3.3.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

 

3.3.3 SMTP server settings 

Connection to the SMTP server 

The SMTP server (Simple Mail Transfer Protocol), or email server, is a server that 
sends emails. POP3 servers or IMAP servers are used for receiving an email. 

You can find the corresponding settings in the 
"LProfToolbox_Email_SMTP_Settings" screen. 

 

Figure 3-5 

 

 

Table 3-10 

Field Explanation 

Server name SMTP server of the email service provider or your own email 
server. 

Please note that the SMTP server can only be specified as a 
computer name or fully qualified domain name (FQDN) or as an IP 
address. 

Port SMTP server port used for sending email. 

Sender name This plain text name is entered as the sender of the email and can 
be defined as required; for example, "Hall1", "Panel123", etc. 

Email address Email sender address of your emails 

Log in Use the login data you defined when you created the email account. 

Password Use the password you defined when you created the email account. 

The information relates to the email sender. You can use any provider for the 
recipient address(es). 

 

3.3.4 Activation of encrypted message transmission using SSL 

Most SSL servers use port 587 for SSL transmission. If sending emails with this 
port fails, consult your email service provider for the correct settings.  
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Verifying the correct port for sending email 

If you are not sure whether your provider supports SSL or communicates via port 
587, perform the following steps on a PC connected to the Internet via the same 
subnet as your operator panel: 

 

Table 3-11 

No. Action 

1. Open the Windows Command Prompt. 

2. Enter the command line "telnet [SMTP server name] 587". (Replace "[SMTP server 
name]" with the actual server name.) 

Note 

The "Telnet" tool is not enabled by default on all Windows installations. If the 
command is not known to your command prompt, use "Control Panel > Programs 
and Features > Turn Windows features on or off" to enable Telnet in Windows 10. 
On other Windows versions, the path may differ slightly. 

3.  If a message appears that a connection cannot be established, port 587 of your 
server is blocked. 

In this case, change the port to the value specified by your email service provider or 
use a different email service provider. 

 

Note If your provider does not support SSL yet, port 25 is used by default for sending 
emails. Please note that your emails are transmitted unencrypted in this case. 
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3.3.5 Settings on the HMI operator panel 

The IPC must be configured for connection to the Internet. 

Make sure that the network access for IPCs is not restricted by domain policies or 
firewalls. (If necessary, contact your domain administrator.) 

 

3.3.6 Option: Forwarding emails as SMS text messages 

General 

Various mobile network operators offer a service that assigns an email address to 
a cell phone number of their network. Emails sent to this address are then 
converted to SMS text messages and forwarded to the mobile device in this format. 
This allows you to receive emails on a cell phone or smartphone without having an 
email client installed. 

 

Note The maximum length of an SMS text message is 160 characters as always. 
Longer emails are normally truncated by the provider. 

Enabling and disabling notification by SMS text message 

For an email to be converted into an SMS text message, the appropriate service 
must be signed up for with the mobile network operator. Using the example of T-
Mobile, the following sections describe how to do this.  

• Enabling reception of email with a provider: 
Send an SMS text message with the text "OPEN" to the T-Mobile speed dial 
number 8000. This opens your T-Mobile number for email reception. 
And the email address assigned to your cell phone is: 
T-Mobile phone number (incl. area code)@t-mobile-sms.de 
e.g. 017100000000@t-mobile-sms.de. 

• Disabling email reception: 
If you no longer want to receive emails, send an SMS text message with the 
text "CLOSE" to the T-Mobile speed dial number 8000. 

The above steps may be different for other mobile network operators. 

Changes on the HMI operator panel are not necessary. 

Other mobile network operators 

The following table lists a selection of providers offering SMS notification services. 
This list does not claim to be complete. 

Table 3-12 lists: 

• The keywords for the activation/deactivation message of the notification 
service, 

• the speed dial number to which the activation/deactivation message has to be 
sent, 

• the email address from which the received messages are forwarded as SMS 
text messages (replace the “[No]” with the appropriate cell phone number). 

• the individual providers’ websites 

mailto:017100000000@t-mobile-sms.de
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Table 3-12 

 Vodafone O2 

Start/end of service OPEN / CLOSE +START / STOP 

Speed dial 3400 6245 

Email address [No]@vodafone-sms.de [No]@o2online.de 

Website http://www.vodafone.de http://www.o2online.de 

For more detailed information, please contact the respective provider and obtain 
information on the "Enable cell phone for receiving email from the Internet" 
function. 

 

3.3.7 Principle of operation of the project 

Automatic assignment of the email recipient 

An email is automatically sent in case of a specific alarm. The address of the 
recipient is determined by a shift schedule in this case. 

The active email address is changed daily at the set times by means of the 
Scheduler. 

As an alternative to the individual alarm, you can also define an alarm class for 
sending emails. If an alarm of this alarm class occurs, an alarm is sent to the 
respective recipient. In this case, you will not need to activate the "Send email" 
function multiple times. 

Description of the script "LProfToolbox_ReadCurrentValues" 

This script is used to restore the last settings saved of the shift schedule. The script 
reads all values of the "Email_shifts.txt" file and writes them to the associated tags. 

Description of the script "LProfToolbox_SendEmailVB" 

This script is used for sending an email manually. The script reads the entered 
recipient address as well as subject and text and sends the email via SMTP 
service. 

Description of the script "LProfToolbox_StartUp" 

This script is executed once by the first call of the start screen. It is used for saving 
and reading the email addresses for the shift schedule and the start times of the 
shifts. To do so, the "Email_shifts.txt" file is created the very first time the script is 
called.  

Plus the start values for the shift times and shift addresses are created. 

Description of the script "LProfToolbox_WriteCurrentValues" 

This script is used to save the complete setting of the shift schedule. The script 
writes the current value of all email addresses and shift schedule times to the 
"Email_shifts.txt" file. 

Description of the script "LProfToolbox_TransferAddressFromDirectory" 

This script changes the email address of the selected shift time. It replaces the 
email address of the shift time by the one selected from the recipe.  

The emails are saved in a recipe as data records. You can expand the recipe by 
any number (max. 5000) of new emails.  

 

http://www.vodafone.de/
http://www.o2online.de/
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Note Storage path of the "Email_shifts.txt" file in Windows operating systems: 

Windows path: C:\Tools\Email_shifts.txt 

 

The same is the case for the recipe that saves the email addresses as data 
records. 

• Windows path:  C:\Tools\Recipes 

 

3.3.8 Project Planning 

Table 3-13 

No. Action 

1. Use the faceplate "SMTP_Settings" for the SMTP settings during runtime. 

Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 
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No. Action 

6. Open the folder "Master copies > HMI > Tools > 02_Transferring Data > Email" of the 
library. 
Drag the corresponding elements to the associated folders of your HMI operator 
panel. 

 

      

7. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_TransferData_ScreenWindow" 

- Configuration "LProfToolbox_TransferData_Configuration"  

- Tag "LProfToolbar_TransferData_Tag". 

 

Alternatively, configure your own screen window by calling the "Email" screen. Note 
that additional steps (e.g. adapting the screen window name in scripts) may be 
necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_TransferData _Toolbar" is automatically transferred with 
the configuration. Check the toolbar and delete the tools that you are not using from 
the toolbar. 
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No. Action 

8. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

 

 

3.3.9 Operation 

Note The SMTP server for sending emails has not been set up in the example project 
yet. You can only test the operation of the user interface. 

If you want to test the full functionality, you still need to adapt the SMTP server 
settings.  

 

Table 3-14 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Data transfer" button. 

 
Open the email window with the "Email" button. 

 
Enter the SMTP settings of your email provider.  
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No. Action 

 

Choose whether you want to send an automatic email (via an alarm) or a manual 
email.  

 

 

 

 

 

 

 

 

 

 

Sending emails manually 

Enter the recipient address, the subject and the body in the appropriate fields. Click 
on "To" to open the address book (see step 7). You can send the email with the 
"Send" button. 

 
 

Sending emails automatically 

Click the button (2) to activate the alarm that sends the automatic email. 

Use the IO fields to specify different email addresses for the respective shift. You 
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No. Action 

can use the buttons (3) to select addresses from the address book (see step 
"Maintenance of the address book"). 

You specify the times of the respective shift with the "From" and "To" I/O fields. 

Use the buttons (4) to save and download the settings for shift times and shift 
addresses. 

 

 

 

 

 

 

Maintenance of the address book 

 
 

Management of the address book has been solved with a faceplate. To add a new 
email address, click the "+" button. 

Select an email address and press the "-" button to delete an email address. 

The addresses are automatically saved in the file system. Click the "Load" button to 
load the addresses. 

Click the "Apply" button when you have selected the desired email address. 
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3.4 Automatic backup of files 

3.4.1 Solution 

Description 

With the aid of automatic backup, your files (e.g., archives) are backed up to any 
location (e.g., a USB flash drive, network folder, etc.) at configurable intervals. 

Figure 3-6 

 

 

3.4.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

 

3.4.3 VBS scripts used 

LProfToolbox_calculateNextExecution 

The "LProfToolbox_calculateNextExecution" script calculates the time for the next 
automatic backup, based on the set time interval. 

LProfToolbox_CopyFiles 

The "LProfToolbox_CopyFiles" script copies the files selected together with date 
and time stamp to the file path selected. 

LProfToolbox_FileSelectCopyFiles 

The "LProfToolbox_FileSelectCopyFiles" script writes the paths of the files to the 
copied into the associated HMI tags. 

LProfToolbox_InitializeTime 

The "LProfToolbox_InitializeTime" script reads the current time and writes it as 
default value for the backup time. 
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LProfToolbox_previousFolder 

The "LProfToolbox_previousFolder" script opens the higher-level folder of the 
currently selected folder. 

LProfToolbox_ReadFilesOfFolder 

The "LProfToolbox_ReadFilesOfFolder" script reads the files from the specified 
path and shows them as a table. 

LProfToolbox_Search 

The "LProfToolbox_Search" script searches for the specified file/folder in the 
current path. 

LProfToolbox_ShowFile 

The "LProfToolbox_ShowFile" script opens the selected folder / file. 

LProfToolbox_WriteFilePropertiesToTags 

The "LProfToolbox_WriteFilePropertiesToTags" script writes the properties of the 
selected folder / file to the associated HMI tags. 

 

3.4.4 Project Planning 

Table 3-15 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 
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No. Action 

6. Open the folder "Master copies > HMI > Tools > 02_Transferring Data > FileCopy" of 
the library. 

Drag the elements to the corresponding folders of the operator panel. 

 

7. Open your start screen. 

8. Add the script "LProfToolbox_ReadFilesOfFolder" under "Properties > Events > 
Loaded". For the "folderpar" parameter, select the "Folder" HMI tag.  
Alternatively, you can enter your own path that starts the File Explorer. 

Add the script "LProfToolbox_WriteFilePropertiesToTags" and select the HMI tag 
"Index" as "index". 

 



3 Data transfer 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  53 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

No. Action 

9. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_TransferData_ScreenWindow" 

- Configuration "LProfToolbox_TransferData_Configuration"  

- Tag "LProfToolbox_TransferData_Tag". 

 

Alternatively, configure your own screen window by calling the 
"LProftoolbox_AutoBackup" screen. Note that additional steps (e.g. adapting the 
screen window name in scripts) may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_TransferData_Toolbar" is automatically transferred with 
the configuration. Check the toolbar and delete the tools that you are not using from 
the toolbar. 

10. Deselect the default configuration under "Menus & toolbar →Configurations". 
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3.4.5 Operation 

Table 3-16 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Data transfer" button. 

 
Open the screen with the "File copy" button. 

 

5. Click on the "Next Backup" button and set up the backup interval for the 
selected files. 

 

Click "Apply" to confirm your entries. 
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No. Action 

6. Click the button with the pen symbol. 

 

7. Open the file path with the "Open" button. 
Select the file you want to back up. 

Confirm the selection with "Apply". 

For a detailed description of the File Explorer, refer to the section 6.2. 

To remove an already selected file from the list again, select the I/O field 
and delete the input. 



3 Data transfer 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  56 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

No. Action 

8. Click on the "Path" button to select the file path for the backup. 

You can also enter the path directly via the I/O field. 

 

9. The files are copied to the specified folder at the set time. The original file 
name is preceded by the current date and the current time. 

10. The times for "Last Backup" and "Next Backup" are automatically updated 
depending on the backup interval. 
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4 Mathematical functions 

4.1 Unit converter 

4.1.1 Solution 

Description 

The unit converter is used to quickly and easily switch between different unit 
systems when displaying process data. While the data can be displayed and 
entered in different systems, the user program in the CPU will not be affected by 
the switchover between the unit systems. Instead, all HMI data is to be 
automatically converted to the CPU’s system of units. 

The example project contains two faceplates for unit conversion between imperial 
and SI system: 

• Length: Millimeters (mm)  inches (in) 

• Temperature: °Celsius (°C)  °Fahrenheit (°F). 

 

Figure 4-1 

 

 

4.1.2 Hardware and software components 

This application example is valid for: 

• WinCC (TIA Portal) V15.1 or higher 

• WinCC Runtime Professional 

The application example was created with WinCC Professional V15.1. 
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4.1.3 Project Planning 

Table 4-1 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC (TIA Portal) configuration. 

Open the "Global libraries" pane with the "Libraries" task card. 

 

3. Click on the second icon from the left to open a global library. 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

5. Open the folder "Master copies > HMI > Tools > 03_Mathematical functions > Unit 
converter" of the library. 

Drag the elements to the corresponding folders of the operator panel. 
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No. Action 

6. Open the LProfToolbox_unitSwitch screen. 

Open the "Properties > Interface" tab of the "Length_Conversion" faceplate. 

The faceplate has three parameters: 

• Int_len_inches (data type: Real) 
Process value in inches (inches)  

• Int_len_mm (data type: Real) 
Process value in millimeters 

• System_used (data type: Bool) 
Specification of the unit system 
0: Metric unit system 
1: Imperial unit system. 
 

 

7. The faceplate "Temp_Conversion" has parameters for temperature conversion. 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Maths_ScreenWindow" 

- Configuration "LProfToolbox_Maths_Configuration"  

- Tag "LProfToolbox_Maths_Tag". 

 

Alternatively, configure your own screen window by calling the 
"LProftoolbox_UnitSwitch" screen. Note that additional steps (e.g. adapting the 
screen window name in scripts) may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Maths_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 
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No. Action 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

 
 

Configuring additional unit conversion 

Table 4-2 

No. Action 

1. In the "Project library" pane open the shortcut menu of the faceplate 
"Length_Conversion_Prof" and select the command "Duplicate type". 

 
 

Assign a meaningful name to the type, for example, "Pressure_Conversion".  

If necessary, adjust the version and enter a comment. 

2. Open the shortcut menu of the "Pressure_Conversion" faceplate and select "Edit 
type". 

3. Select the "Properties" tab in the configuration area of the faceplate and open the 
view of the interface parameters in the right screen area with the black arrow. 

Note The use of two HMI tags (Length_inches and Length_mm) is for demonstration 
purposes only. In practice, only one tag is used in the process. 
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No. Action 

4. In the Inspector window under the "Properties" tab, adjust the names of the 
parameters of both I/O fields in the "Properties" tab.  

 

5. Select an I/O field and enter the conversion formula for the unit system under 
"Properties > Events > Object changed". Repeat this step for the second I/O field. 

6. Double-click one of the I/O fields. Specify the unit of the value under "Properties > 
Appearance > Unit".  

 

7. Repeat step 6 for the second IO field and position the IO fields on top of each other 
again. 
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No. Action 

8. Open the shortcut menu of the faceplate and select "Release version".  
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4.1.4 Operation 

Table 4-3 

No. Action 

1. Open the example project "106226404_ExampleProject_Professional" that you can 
download on the download page of this entry.  

2. Download the configuration to your operator panel. 

3. Click on the "Mathematical functions" button.  

 
Select the "Unit converter" button.  

 

4. Enter the values in the two I/O fields. Change the unit for the switch. 

 

 
  



4 Mathematical functions 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  64 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

4.2 Calculator 

4.2.1 Solution 

Description 

Visualization devices are often located directly in the production plant. The operator 
not only monitors the production process but also controls the availability of 
materials. To do so, individual process variables may frequently have to be 
calculated. The HMI calculator offers the standard arithmetic functions, such as "+" 
and "-" for this purpose. 

Figure 4-2 

 

 

4.2.2 Hardware and software components 

This application example is valid for: 

• WinCC (TIA Portal) V15.1 or higher 

• WinCC Runtime Professional: 

The application example was created with WinCC V15.1. 
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4.2.3 Project Planning 

Table 4-4 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC (TIA Portal) configuration. 

Open the "Global libraries" pane with the "Libraries" task card. 

 

3. Click on the second icon from the left to open a global library. 

 

4. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

5. Open the folder "Master copies > HMI > Tools > 03_Mathematical functions > 
Calculator" of the library. 

Drag the elements to the corresponding folders of the operator panel. 
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No. Action 

6. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Maths_ScreenWindow 

- Configuration "LProfToolbox_Maths_Configuration"  

- Tag "LProfToolbox_Maths_Tag". 

 

Alternatively, configure your own screen window by calling the 
"LProfToolbox_Calculator" screen. Note that additional steps (e.g. adapting the 
screen window name in scripts) may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Maths_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

 

7. Deselect the default configuration under "Menus & toolbar →Configurations". 
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4.2.4 Operation 

Table 4-5 

No. Action 

1. Open the example project "106226404_ExampleProject_Professional" that you can 
download on the download page of this entry. 

2. Download the configuration to your operator panel. 

3. Click on the "Mathematical functions" button. Open the calculator with the 
"Calculator" button. 

 
Select the "Calculator" button.  

 

4. You operate the calculator as you would any standard calculator. 
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5 Simplified operation 

5.1 Segmented control 

5.1.1 Solution 

Description 

A segmented control helps you to clearly and quickly define values. This allows you 
to specify potential values beforehand and avoid operating errors. 

 

Variable specification of a value in equidistant steps between a minimum and a 
maximum value (can be set during runtime). The display can be changed via the 
interface of the block. 
 

Figure 5-1 

 

 

A screen window is available for SIMATIC WinCC RT Professional. You can use 
this screen window to specify the number of steps (maximum of 30) as well as the 
minimum and maximum value.  

The values and the labeling of the buttons is calculated in equidistant steps.  

The connection takes place by means of a user-defined data type. You use the tag 
prefix of the screen window to specify which tag is to be controlled. 
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5.1.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• WinCC RT Professional V15.1 

 

5.1.3 Project Planning 

Table 5-1 

No. Action 

1. Download the library "106226404_LProfToolbox.zip". Unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 04_Simplified Operation > 
SegmentedControl" of the library. 

           

7. Drag the elements to the corresponding folder of the HMI operator panel. 
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No. Action 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Operation_ScreenWindow" 

- Configuration "LProfToolbox_Operation_Configuration" 

- Tag "LProfToolbox_Operation_Tag": 

 

Alternatively, configure your own screen window by calling the "SegmentedControl" 
screen. Note that additional steps (e.g. adapting the screen window name in scripts) 
may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Operation_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

10. Adapt the function "ActivateScreenInScreenWindow" to your configured screen with 
screen window. 
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5.1.4 Operation 

Table 5-2 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional" and 
unzip the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click on the "Simplified operation" button. 

 

5. Open the screen window with the "Segmented Control" button. 

 

6. In the "Number of fields" I/O field enter the number of fields into which the control is 
to be subdivided. 

Enter the limits between which the values must be specified in the "Minimum" and 
"Maximum" I/O fields. 

Click "Apply" to apply the settings. 

Click on a field to specify the tag value.  

 

 

 



6 Enhanced clarity 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  72 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

6 Enhanced clarity 

6.1 Notes 

6.1.1 Solution 

Description 

Notes help the operator of the IPC to process text notes. The tool saves the 
entered notes in a text file to the memory of the HMI operator panel. 

Notes can be written, read, edited and shared with other operators this way. 

 

Figure 6-1 

 

 

6.1.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 
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6.1.3 Project Planning 

Table 6-1 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. To do this, open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a global library. 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 05_Increase clarity > Notes" of the 
library. 

 

7. Drag the elements to the corresponding folder of the HMI operator panel. 
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No. Action 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Clarity_Screenwindow" 

- Configuration "LProfToolbox_Clarity_Configuration"  

- Tag "LProfToolbox_Clarity_Tag". 

 

Alternatively, configure your own screen window by calling the "Notes" screen. Note 
that additional steps (e.g. adapting the screen window name in scripts) may be 
necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Clarity_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 
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6.1.4 Operation 

Table 6-2 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Click the "Increase clarity" button. 

 

4. Open the notes with the "Notes" button. 

 

5. Enter your notes using a multi-line text (1). 

Enter the storage path where you want to save the notes in the I/O field (2).  

You can load or save the notes with the "Save" and "Load" buttons (3). 
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6.2 File Explorer 

6.2.1 Solution 

Description 

The default file browser allows you to select any file in the file system of the 
operator panel and save it in your project as a WinCC tag for further use. 

The File Explorer that you can download in this application example enables you to 
use extended file functions such as "Delete", "Rename" or "Search" of files / 
folders. The File Explorer is fully integrated into the runtime environment so that the 
operator does not need to access the operating system. 

 

Figure 6-2 

 

 

6.2.2 Hardware and software components 

This application example is valid for: 

• WinCC Professional V15.1 

• WinCC RT Professional V15.1 
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6.2.3 VBS scripts used 

LProfToolbox_FileExplorer_CreateFolder 

The "LProfToolbox_FileExplorer_Create Folder" script creates a new folder in the 
file system. 

LProfToolbox_FileExplorer_delete 

The "LProfToolbox_FileExplorer_Delete" script deletes the selected file/folder from 
the file system.  

LProfToolbox_FileExplorer_move 

The "LProfToolbox_FileExplorer_move" script allows copying, cutting and pasting 
the selected file in the file system. The "sender" transfer parameter defines the 
mode: 

• sender = 1: copy 

• sender = 2: paste 

• sender = 3: cut 

LProfToolbox_FileExplorer_previousFolder 

The "LProfToolbox_FileExplorer_previousFolder" script opens the higher-level 
folder of the currently selected folder. 

LProfToolbox_FileExplorer_ReadFilesOfFolder 

The "LProfToolbox_FileExplorer_ReadFilesOfFolder" script reads the files from the 
specified path and shows them as a table. 

LProfToolbox_FileExplorer_Rename 

The "LProfToolbox_FileExplorer_Rename" script renames the selected file / folder.  

LProfToolbox_FileExplorer_Search 

The "LProfToolbox_FileExplorer_Search" script searches for the specified file / 
folder in the current path. 

LProfToolbox_FileExplorer_ShowFile 

The "LProfToolbox_FileExplorer_ShowFile" script opens the selected folder / file. 

LProfToolbox_FileExplorer_WriteFilePropertiesToTags 

The "LProfToolbox_FileExplorer_WriteFilePropertiesToTags" script writes the 
properties of the selected folder / file to the associated HMI tags. 
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6.2.4 Project Planning 

Table 6-3 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. To do this, open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a global library. 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 05_Increase clarity > FileExplorer" 
of the library.  

Drag the elements to the operator panel.  

      

7. Open your start screen. 
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No. Action 

8. Drag the following objects from the library to your project: 

- Screen window "LProfToolbox_Clarity_Screenwindow" 

- Configuration "LProfToolbox_Clarity_Configuration"  

- Tag "LProfToolbox_Clarity_Tag". 

 

Alternatively, configure your own screen window by calling the 
"LProfToolbox_FileExplorer" screen. Note that additional steps (e.g. adapting the 
screen window name in scripts) may be necessary in this case. 

 
 

Note: 

The toolbar "LProfToolbox_Clarity_Toolbar" is automatically transferred with the 
configuration. Check the toolbar and delete the tools that you are not using from the 
toolbar. 

 

9. Deselect the default configuration under "Menus & toolbar →Configurations". 

 

 

Note Note that the File Explorer gives the operator access to all files of the operator 
panel. Therefore, use appropriate operator authorizations to protect the File 
Explorer. 
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6.2.5 Operation 

Table 6-4 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Increase clarity" button. 

 
Open the File Explorer with the "File Explorer" button. 

 

5. The File Explorer opens. The default path setting is "C:\" (Computer – Windows). 
Select a folder and open it with "Open". 

 
 

Note 
Due to the space requirements on the operator panel, very long path names will not 
be displayed (approx. 60 or more characters). If you regularly use longer path 
names, resize the file browser and the I/O fields to suit your requirements. 

6. Press the "Back" button to open the previous folder. 

7. Press the "New" button to create a new folder in the current directory.  
Enter the name of the folder and select "Apply". Use "Cancel" to cancel the action 
without creating a folder. 

 

8. Click "Open" to open a folder or a file. 

Note 
For PC-based systems the possible data formats depend on your installed 
programs. 
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No. Action 

9. Press the "Delete" button to delete the selected element. Only empty folders can be 
deleted. 
Confirm the security prompt with "Apply" if you really want to delete the element or 
cancel the process with "Cancel". 

 

10. Click the "Rename" button to rename the selected file. 

Enter a new name and confirm with "Apply" to apply the name or cancel the process 
with "Cancel". 

 

11. Select Copy or Cut to copy or move a selected element. Navigate to the desired 
path and select "Paste". 

Folders cannot be copied / cut. 

12. Click on the "Search" button and enter the character string which is to be searched 
for. Start the search with "Apply". 

 

13. The currently open folder is searched and the results are displayed in the list. 
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Note The bottom part of the window includes a status bar. 
Note that some file operations (e.g. delete, search) may take some time. Wait 
therefore until the status bar confirms successful execution. 
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6.3 Waiting view 

6.3.1 Solution 

Description 

The waiting view allows you to inform the operator when a function (e.g. script 
execution) still needs time. This also prevents operator errors. 

Three versions of the waiting view are available: 

• Circle - Screen object  

• Rectangle - Screen object  

• Text - Screen object  

 

Figure 6-3 

 

 

6.3.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 
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Project Planning 

Table 6-5 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 05_Increase clarity > Waiting view" 
of the library. 

7. Drag the elements to the corresponding folders of the operator panel.  
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6.3.3 Operation 

Table 6-6 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Increase clarity" button. 

 
Open the screen with the "Wait time preview" button. 

 

5. The different waiting views are shown animated. 
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6.4 CMD 

6.4.1 Solution 

Description 

With the help of the command prompt (CMD), the operator can execute CMD 
commands within the WinCC Runtime. 

 

Figure 6-4 

 

6.4.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 
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Project Planning 

 

Table 6-7 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 05_Increase clarity > CMD" of the 
library. 
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No. Action 

7. Drag the elements to the corresponding folders of the operator panel. 
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6.4.3 Operation 

Table 6-8 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Increase clarity" button. 

 
Open the screen with the "CMD" button. 

 

5. VB scripts execute 2 different CMD commands "ping" and "ipconfig". 
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6.5 Bit monitor 

6.5.1 Solution 

Description 

The bit monitor allows you to visualize positive, integer HMI tags (USINT - Byte, 
UINT - Word, UDINT - Double) bit by bit. This is particularly useful during 
commissioning and when analyzing error states.  

The bit views are available as faceplates for 8-bit (data type: USINT), 16-bit (data 
type: UINT) and 32-bit tags (data type: UDINT) and can be used independent of 
one another.  

• Variable " InputByte ",  

• Variable " InputWord ",  

• Variable " InputDouble ",  

 

The animation function masks the individual bits. 

 

Figure 6-5 
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6.5.2 Hardware and software components 

This application example is valid for: 

• SIMATIC WinCC Professional V15.1 

• SIMATIC WinCC RT Professional V15.1 

 

Project Planning 

Table 6-9 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card. 

 

4. Click on the second icon from the left to open a "Global Library". 

 

5. Select the file "LProfToolbox.al15_1" and open the library with the "Open" button. 

6. Open the folder "Master copies > HMI > Tools > 05_Increase clarity > Bit monitor" of 
the library. 
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No. Action 

7. Drag the elements to the corresponding folders of the operator panel. 
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6.5.3 Operation 

Table 6-10 

No. Action 

1. Download the example project "106226404_ExampleProject_Professional_zip" and 
unpack the file. 

2. Open the project with the TIA Portal. 

3. Download the configuration to your PC station or start the simulation. 

4. Click the "Increase clarity" button. 

 
Open the screen with the "BitMonitor" button. 

 

5. The different bit monitors for the data types USINT, UINT and UDINT are displayed. 

 

 



7 Simplified engineering 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  94 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

7 Simplified engineering 

7.1 Siemens icon font 

7.1.1 Solution 

Description 

Siemens provides you with a font containing a large selection of icons that you can 
use as text, for example, for buttons.  
In addition to the icons the font also contains a normal character set. This character 
set corresponds to the character set of the "Siemens Sans" font. 

The documentation gives you a clear overview about available icons and shows 
you how to integrate such icons into your own project. 

The file "106226404_SiemensIconFont.zip" contains the 
"SiemensTIAPortalIcons.ttf" font. 

In the example project "106226404_ExampleProject_Professional_zip ", the icons 
are used as text on the buttons, and a color switching is used as example to show 
you how you can make use of the diverse dynamic sampling options. 

Figure 7-1 

 

Advantages through the use of icons 

• Easy multilingual engineering 
You can use the icons in any language as they are understood without 
translation. For other languages, just copy the text list of the language you 
have already parametrized. 

• Free scaling 
Characters are freely scalable. Unlike with graphics, you must not pay attention 
to the size or the resolution of the source material. Free scaling avoids possible 
built-up of artefacts / blurring effects when zooming in on / zooming out of 
screens. 

• Automatic transparency 
Icon characters of the font have a transparent background. You must not pay 
attention to set the background transparent or color it according to the project 
color. 
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7.1.2 Hardware and software components 

Validity 

This application example is valid for: 

• SIMATIC WinCC Professional and RT Professional V15 and higher 

 

 

7.1.3 Available icons 

The "Siemens TIA Portal Icons Standard" font includes a large selection of icons 
which are shown in the table below. 

 

Note The ASCII characters 61824 to 61857 are supported in WinCC Professional only  
as of TIA V14 SP1. 

 

Table 7-1 

HEX ASCII Character HEX ASCII Character HEX ASCII Character 

F101 61697  F102 61698  F103 61699  
F104 61700  F105 61701  F106 61702  
F107 61703  F108 61704  F109 61705  
F10A 61706  F10B 61707  F10C 61708  
F10D 61709  F10E 61710  F10F 61711  
F110 61712  F111 61713  F112 61714  
F113 61715  F114 61716  F115 61717  
F116 61718  F117 61719  F118 61720  
F119 61721  F11A 61722  F11B 61723  
F11C 61724  F11D 61725  F11E 61726  
F11F 61727  F120 61728  F121 61729  
F122 61730  F123 61731  F124 61732  
F125 61733  F126 61734  F127 61735  
F128 61736  F129 61737  F12A 61738  
F12B 61739  F12C 61740  F12D 61741  
F12E 61742  F12F 61743  F130 61744  
F131 61745  F132 61746  F133 61747  
F134 61748  F135 61749  F136 61750  
F137 61751  F138 61752  F139 61753  
F13A 61754  F13B 61755  F13C 61756  
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HEX ASCII Character HEX ASCII Character HEX ASCII Character 

F13D 61757  F13E 61758  F13F 61759  
F140 61760  F141 61761  F142 61762  
F143 61763  F144 61764  F145 61765  
F146 61766  F147 61767  F148 61768  
F149 61769  F14A 61770  F14B 61771  
F14C 61772  F14D 61773  F14E 61774  
F14F 61775  F150 61776  F151 61777  
F152 61778  F153 61779  F154 61780  
F155 61781  F156 61782  F157 61783  
F158 61784  F159 61785  F15A 61786  
F15B 61787  F15C 61788  F15D 61789  
F15E 61790  F15F 61791  F160 61792  
F161 61793  F162 61794  F163 61795  
F164 61796  F165 61797  F166 61798  
F167 61799  F168 61800  F169 61801  
F16A 61802  F16B 61803  F16C 61804  
F16D 61805  F16E 61806  F16F 61807  
F170 61808  F171 61809  F172 61810  
F173 61811  F174 61812  F175 61813  
F176 61814  F177 61815  F178 61816  
F179 61817  F17A 61818  F17B 61819  
F17C 61820  F17D 61821  F17E 61822  
F17F 61823  F180 61824  F181 61825  
F182 61826  F183 61827  F184 61828  
F185 61829  F186 61830  F187 61831  
F188 61832  F189 61833  F18A 61834  
F18B 61835  F18C 61836  F18D 61837  
F18E 61838  F18F 61839  F190 61840  
F191 61841  F192 61842  F193 61843  
F194 61844  F195 61845  F196 61846  
F197 61847  F198 61848  F199 61849  
F19A 61850  F19B 61851  F19C 61852  
F19D 61853  F19E 61854  F19F 61855  
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HEX ASCII Character HEX ASCII Character HEX ASCII Character 

F1A0 61856  F1A1 61857     

7.1.4 Installing the font 

Installation in Windows 7 

There are three options to install the font under Windows 7.  

Unzip the "106226404_SiemensIconFont.zip" file into a folder of your choice for 
installation. The "SiemensTIAPortalIcons.ttf" file contains the "Siemens TIA Portal 
Icons Standard" font. 

Note Close all instances of the TIA Portal prior to the installation.  

If an instance of the TIA Portal was open during the installation of the font, close 
the TIA Portal and then restart it. 

Option 1 

Table 7-2 

No. Action 

1. Double-click the "SiemensTIAPortalIcons.ttf" file to open it. The font preview opens. 

2. Click "Install". 

 
Note 
You need to have the required administrator rights to do this. 

3. Complete the installation. 
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Option 2 

Table 7-3 

No. Action 

1. Right-click the "SiemensTIAPortalIcons.ttf" file. The shortcut menu opens. 

 

2. Click "Install". 

 

 
 

Note 
You need to have the required administrator rights to do this. 

3. Complete the installation. 

Option 3 

Table 7-4 

No. Action 

1. Select the file "SiemensTIAPortalIcons.ttf" and copy the file using the key 
combination <Ctrl> + <C>. 

2. Open the "Fonts" folder in the Control Panel. 

3. Add the "SiemensTIAPortalIcons.ttf" file with the key combination <Ctrl> + <V>. 

 

 

Integrating the font into your project 

Note When you configure a PC station with SIMATIC WinCC Professional, you do not 
have to integrate the font. You only have to install the font. All installed fonts of 
the Windows operating system are available for the configuration. 

 

  



7 Simplified engineering 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  99 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

7.1.5 Using the font 

Setting the font, font style and font size 

You have to manually customize the font, as well as associated font style and font 
size for basic objects and elements. 

Table 7-5 

No. Action 

1. Select the basic object or element in which the symbol is to be displayed. 

2. Click on "Properties > Text format". 

3. In "Format > Font", click the "…" button. 

4. Select the "Siemens TIA Portal Icons" font and make the desired settings for "Font 
style" and "Size". 

5. Click on "OK". 

 

Text input of the icon 

Table 7-6 

No. Action 

1. Select the basic object or element in which the symbol is to be displayed. 

2. Click on "Properties > General". 

Note 

Make sure that "Text" or "Graphics and text" is selected as mode under "Buttons". 

3. Click in the input box for the text input. 

4. Press and hold the <Alt> key and enter the "ASCII" character code of the icon.  

Note: 

You can find the description in Chapter 7.1.3. 

5. Release the <Alt> key. 

6. Press "Enter" or click an area outside of the "General" window. The icon appears as 
text of the object. 
The icon is not displayed in the input area of the "General" window. A square 
indicates that the input was successful. 

 

Note 
An input error has occurred or an incorrect "ASCII" code was entered if no text, a 
question mark or an unexpected icon appears in the input field. 

→ Solution: Erase the text and repeat the input. 

 

Note The sequence of the steps "Setting of font, font style and font size" and "Text 
input of the icon" can be changed, but the sequence specified here is 
recommended. The font can also be used when entering text in text lists.  

You can write several icons one after the other just like text characters. Simply 
repeat the input.  

A combination of symbol and text is also possible. The font size depends on the 
default text format of the basic object or element. 
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Positioning the icons  

Under "Properties > Text format > Alignment" you can set the general horizontal 
and vertical alignment of the font. 

Follow the description below to more accurately position the icon on the basic 
object or element. 

 

Table 7-7 

No. Action 

1. Select the basic object or element with the icon. 

2. Click on "Properties > Layout". 

3. Enter the desired margins under "Text margins". 

 

Multilingual configuration of icons 

Table 7-8 

No. Action 

1. Open the "Languages & resources > Project texts" folder in the project tree. 

2. Scroll down; the symbols and special characters are at the end of the list and can be 
identified by the square character (in standard sorting). 

3. Select all icons.  
Select the first entry and scroll down to the last entry. Keep the <Shift> key pressed 
and select the last entry. 

4. Copy the selected area. Scroll to the first icon entry. 

5. Next to the first icon entry, click the cell of another configured language. Paste the 
copied area. 

6. Repeat the last item for each configured language. 
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Transferring the font style and other objects 

Within a screen, you can assign the same font style to several objects all at once. 

Table 7-9 

No. Action 

1. Draw a frame around the desired objects or click a single object. To interconnect 
several selections, press and hold the <Shift> key and draw additional frames or 
select additional single objects. 

2. To remove an object from the selection, keep holding down  
the <Shift> key and click the object you wish to remove from the selection. 

3. Release the <Shift> key and click "Properties". 

Assign the font and the font style as described in the chapter "Setting the font, font 
style and font size". 

If the desired target objects are not in the same screen, you can copy the set font 
style and paste it into the desired object. 

 

4. In the "Text format" window, right-click the font and select "Copy" (or select the 
entry and use the shortcut <Ctrl>+<C>). 

5. Select the desired object and select the available font in the "Text format" window. 

6. Right-click the selected area and select "Paste" (or use the shortcut <Ctrl>+<V>). 

 

You can also copy an object for which you have already set the font and the style. 
The properties are retained in the process. 

 

7.1.6 Project Planning 

Note The library for the project was created with TIA Portal V15 and can therefore only 
be opened with a version V15 or higher. 

Table 7-10 

No. Action 

1. Download the library "106226404_LProfToolbox.zip" and unzip the file to the project 
directory of the global libraries. 

2. Open your WinCC configuration. 

3. Open the "Global libraries" pane in the "Libraries" task card and click on the second 
icon from the left to open a global library.  

 

4. Select the file "LProfToolbox.al15" and open the library with the "Open" button. 
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No. Action 

5. Under "Master copies" drag and drop the screens and tag tables to the associated 
folders of your configuration.  

 

6. Create a new button and create the click event "Activate Screen" and connect the 
HMI screen "LProfToolbox_Icons". 
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7.1.7 Operation  

Table 7-11 

No. Action 

1. Download the file "106226404_ExampleProject_Professional_zip"  
and unpack the files into a directory of your choice. 

Note: 

The font must be installed for operation of the example project. 

2. Open the project. 

3. Compile the HMI operator panel and then start the simulation. 

4. Click on the "Simplified engineering" button in the navigation bar at the bottom. 

 

5. Open the screen with the "Wait time preview" button. 

 

6. Click on one of the colors in the "Icon color" area. 
The icon color of the icons changes to the selected color. 

7. Click on one of the color gradients in the "Flash color" area. The icon and 
background color switches between the selected colors at continuous intervals. 

8. Press the buttons with the arrows to change between the individual icons. 
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7.2 Rotation tool 

7.2.1 Solution 

Description 

In addition to color, motion is a good medium to simply and clearly illustrate the 
status of a machine, for example. It can, for example, be used to illustrate pumps, 
fans, motors, mixers, or gears. 

The "Rotation Tool" is a Microsoft PowerPoint Add-In that you can use to 
automatically rotate and save screens in different status conditions as a png file. 
Optionally, you can directly create an xml file which you can import as a graphics 
list directly into the HMI project using TIA Portal Openness. 

 

Figure 7-2 

 

 

The gauge controls for Basic Panels that you can also download on the download 
page of this entry were also created using the Rotation Tool. 
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Figure 7-3 

Microsoft

PowerPoint

TIA Portal

Creating a graphical I/O field 

from graphic list and control variable

PNG graphics

Inserting the 
graphics 

into the project

XML file?

Manual
creation

of the graphics list

Import
via the TIA Portal

Openness

Control

variable

yesno

Creating rotating graphics using the rotation tool

 

 

7.2.2 Hardware and software components 

This application example is valid for: 

• Microsoft PowerPoint 2010 

• WinCC (TIA Portal) V15.1 or higher 

• Optional: TIA Portal Openness. 
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7.2.3 Installation 

Table 7-12 

No. Action 

1.  Download the file "HmiEng.zip" and unzip the folder.  

2.  Open Microsoft PowerPoint. Click on "Developer". 

If the "Developer" tab is not displayed, you must first make it visible. (See 
Microsoft Office Support entry) 

3.  Click on "Visual Basic".  

 

4.  Under "Options > References", enable the references "Visual Basic For 
Applications", "Microsoft PowerPoint Object Library" and "Microsoft Forms Object 
Library". 

5.  Click on "Add-ins".  

 

6.  Click "Add new...". 

7.  Select the "HMI_GraphicList_Designer.ppa" file in the unzipped folder and 
confirm your selection with "Open". 

8.  Confirm the security prompt with "Enable macros". 

9.  Close the "Add-ins" window. 

 

  

https://support.office.com/en-us/article/show-the-developer-tab-e1192344-5e56-4d45-931b-e5fd9bea2d45?ui=en-US&rs=en-US&ad=US
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7.2.4 Operation 

Table 7-13 

No. Action 

1.  Create a new PowerPoint presentation with a slide. 

Add the desired screen elements. 

2.  Add a rectangle as background to the slide. Select "Shape Fill > No Fill" and 
"Shape Outline > No Outline".  

Make sure that the selected rectangle is big enough to completely house the 
rotating objects in any position. 

As a result, all screens are saved in the same size. 

Note that circles, too, have a rectangular frame in PowerPoint so that they are 
displayed wider during rotating. 

 

3.  Click on "Add-Ins > HMI GraphicList Designer > Rotation" to start the tool. 

 

4.  In the "Settings" window select the direction of rotation and the angle of rotation. 

Select the intermediate steps of the rotation or number of steps or size of the 
angle of an intermediate step using the selection list. 
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No. Action 

5.  In the "Select" window, select the objects you wish to rotate and click the ">" 
arrow. 

 

6.  In the "Run" window check if a graphics list shall be created as an XML file for 
import with TIA Portal Openness. 

7.  Open your TIA Portal project. 

In the project tree, open "Languages & Resources > Graphics library". 

Drag and drop the screens from the Explorer to the graphics library. 

8.  Import via TIA Portal Openness 

Download the "TiaPortalOpennessDemo" demo application in the entry.  

If you do not yet use TIA Portal Openness, download the documentation and 
install TIA Portal Openness as described. 

Link the application with the project and import the graphics list as described in 
the documentation. 

9.  Manual import 

Create a new graphics list in your operator panel. 

Insert the screens from the graphics library into the graphics list and adapt the 
values. 

10.  Create a new screen in your operator panel. Add a graphic I/O field. 

11.  Under "Properties > Properties > General > Contents > Graphics list:", connect 
the related graphics list. 

12.  Specify the associated process tag under "Process > Tag:". 
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7.2.5 Tips and tricks 

Determining the start position 

The Rotation Tool changes the "Rotation" property of a screen object. 
Before the first screen is created, the "Rotation" value of any rotating element is set 
to 0°. 

If a rotating element is to start at an angle other than 0°, right-click the element in 
the desired start position and click "Save as graphic...". Save the element in PNG 
format. Then insert the element as a graphic into the PowerPoint screen again. 

Setting the rotation axis 

The elements selected in the tool rotate through their center point. To choose 
another rotation axis, it is useful to group the desired element with a hidden 
element and then select the entire group for rotation. 

 

Figure 7-4 

 

 

7.2.6 Continuous rotation 

The tool creates in a first step a screen at a 0° rotation (initial state). 

A rotation of 360° corresponds to 0°. For a graphic intended to continuously rotate 
through its own axis you should consider that the last intermediate step must be 
dropped to prevent two identical screens from following one another.  

One way to achieve this is by skipping the graphics list element 0 or 100 when 
triggering via the control tag (e.g. "startValue" =1).  

Alternatively, subtract the angle size of an intermediate step from the overall 
rotation angle to be able to select a step number reduced by 1 in the Rotation Tool.  
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Figure 7-5 

 

 

7.2.7 Creating the control tag 

If you intend not to display a real rotation of one of the objects contained in your 
process with the rotating object but simulate the rotation, you must create the 
control tag manually. 

To do so you can use, for example, the "SimulateTag" system function at the 
"Loaded" event of the screen. In this case the object will always rotate when the 
screen is displayed. 

If you want to also start and stop the rotation, you can use the STEP 7 function 
"LGF_SawTooth". 

 



8 Appendix 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  111 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

8 Appendix 

8.1 Service and support  

Industry Online Support 

Do you have any questions or need assistance?  

Siemens Industry Online Support offers round the clock access to our entire 
service and support know-how and portfolio. 

The Industry Online Support is the central address for information about our 
products, solutions and services.  

Product information, manuals, downloads, FAQs, application examples and videos 
– all information is accessible with just a few mouse clicks: 
https://support.industry.siemens.com 
 

Technical Support 

The Technical Support of Siemens Industry provides you fast and competent 
support regarding all technical queries with numerous tailor-made offers  
– ranging from basic support to individual support contracts. Please send queries 
to Technical Support via Web form: 
www.siemens.com/industry/supportrequest 
 

SITRAIN – Training for Industry  

We support you with our globally available training courses for industry with 
practical experience, innovative learning methods and a concept that’s tailored to 
the customer’s specific needs. 

For more information on our offered trainings and courses, as well as their 
locations and dates, refer to our web page: 
www.siemens.com/sitrain  
 

Service offer 

Our range of services includes the following:  

• Plant data services 

• Spare parts services 

• Repair services 

• On-site and maintenance services 

• Retrofitting and modernization services 

• Service programs and contracts 

You can find detailed information on our range of services in the service catalog 
web page: 
https://support.industry.siemens.com/cs/sc 
 

Industry Online Support app 

You will receive optimum support wherever you are with the "Siemens Industry 
Online Support" app. The app is available for Apple iOS, Android and Windows 
Phone:  
https://support.industry.siemens.com/cs/ww/en/sc/2067 

https://support.industry.siemens.com/
http://www.siemens.com/industry/supportrequest
http://www.siemens.com/sitrain
https://support.industry.siemens.com/cs/sc
https://support.industry.siemens.com/cs/ww/en/sc/2067


8 Appendix 

 

HMI Toolbox 
Entry ID: 106226404,    V5.0,    02/2019  112 
 

©
 S

ie
m

e
n

s
 A

G
 2

0
1

9
 A

ll 
ri

g
h

ts
 r

e
s
e

rv
e

d
 

8.2 Links and literature  

Table 8-1 

No. Topic 

\1\ Siemens Industry Online Support 

https://support.industry.siemens.com 

\2\ Link to the article page of the application example  

https://support.industry.siemens.com/cs/ww/en/view/106226404 

\3\ Application example "Library with general functions (LGF) for STEP 7 (TIA Portal) 
and S7-1200 / S7-1500" 

https://support.industry.siemens.com/cs/ww/en/view/109479728 

\4\ Link to Wikipedia entry on the topic "Reed Solomon" 

http://en.wikipedia.org/wiki/Reed%E2%80%93Solomon_error_correction 

\5\ Link to homepage of the barcode font type provider "Logitogo" 

http://www.logitogo.com/html/barcode39_erstellen.html 

\6\ Microsoft Office Support entry "Show the Developer tab" 

https://support.office.com/en-us/article/show-the-developer-tab-e1192344-5e56-
4d45-931b-e5fd9bea2d45?ui=en-US&rs=en-US&ad=US 

\7\ TIA Portal Openness: Introduction and Demo Application 

https://support.industry.siemens.com/cs/ww/en/view/108716692 

\8\ WinCC Advanced V13.0 SP1 Manual section "SimulateTag" 
https://support.industry.siemens.com/cs/ww/en/view/109091876/56856939915 

 

 

8.3 Change documentation 

Table 8-2 

Version Date Change 

V1.0 02/2016  First version 

V2.0 06/2017 Revised version 

V3.0 07/2018 Revised version 

Update tools 

V4.0 09/2018 • Functional and design revision of all tools 

• Shared documentation for all tools  
WinCC Runtime Professional V15 

• Release for V15 

V5.0 02/2019 Revised version 

Update tools 

 

 

https://support.industry.siemens.com/
https://support.industry.siemens.com/cs/ww/de/view/106226404
https://support.industry.siemens.com/cs/ww/en/view/109479728
http://en.wikipedia.org/wiki/Reed%E2%80%93Solomon_error_correction
http://www.logitogo.com/html/barcode39_erstellen.html
https://support.office.com/en-us/article/show-the-developer-tab-e1192344-5e56-4d45-931b-e5fd9bea2d45?ui=en-US&amp;amp;rs=en-US&amp;amp;ad=US
https://support.office.com/en-us/article/show-the-developer-tab-e1192344-5e56-4d45-931b-e5fd9bea2d45?ui=en-US&amp;amp;rs=en-US&amp;amp;ad=US
https://support.industry.siemens.com/cs/ww/en/view/108716692
https://support.industry.siemens.com/cs/ww/en/view/109091876/56856939915
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